Home > SharePoint 2010 > Process ‘SPUCWORKERPROCESS.exe’ is not running

Process ‘SPUCWORKERPROCESS.exe’ is not running

Recently , I tried to create a sand boxed solution for SharePoint 2010 beta using Visual Studio 2010 Beta 2.I have created a “Hello World” web part. When I pressed F5 in Visual Studio 2010, I got the following warning message even I have already got Microsoft SharePoint Foundation User Code Service started.

---------------------------
Microsoft Visual Studio
---------------------------
Unable to attach. Process 'SPUCWORKERPROCESS.exe' is not running on 'WIN-MP9OQOTCKB2'.

Do you want to continue anyway?
---------------------------
Yes No
---------------------------

After using google.bing.com, I have found out the Sand boxed solution does not work on DC(Domain controller).If you are using SharePoint on DC, the following Windows PowerShell command would need to be run to enable Sandboxed Solutions.


$acl = Get-Acl HKLM:\System\CurrentControlSet\Control\ComputerName
$person = [System.Security.Principal.NTAccount]"Users"
$access = [System.Security.AccessControl.RegistryRights]::FullControl
$inheritance = [System.Security.AccessControl.InheritanceFlags]"ContainerInherit, ObjectInherit"
$propagation = [System.Security.AccessControl.PropagationFlags]::None
$type = [System.Security.AccessControl.AccessControlType]::Allow
$rule = New-Object System.Security.AccessControl.RegistryAccessRule($person, $access, $inheritance, $propagation, $type)
$acl.AddAccessRule($rule)
Set-Acl HKLM:\System\CurrentControlSet\Control\ComputerName $acl

kick it on DotNetKicks.com

About these ads
Categories: SharePoint 2010
  1. tobie
    September 5, 2010 at 4:06 pm

    “Users” in $person = [System.Security.Principal.NTAccount]”Users” must be translate in foreign language.

  2. Venky
    February 14, 2012 at 9:43 am

    Please help me here with F5 in simple Farm dev environment: I have purchased your book on SP2010 long back and never had issues with F5 debugging in VS 2010:

    I have two server farm 1. App server Windows Server 2008 R2 + VS 2010 professional
    + SQL sevrer windows server 2008 SP2

    In Task manager, I only see SPUCHostService.exe and SPUCWorkerProcessProxy.exe at times and never see SPUCWorkerProcess.exe appears in processes.

    1) Activated/Deactivated user solution using sitecollection admin credentials
    2) OOB sandbox code Deployment went successfully
    3) When I run from any client machines and try to add sandbox webpart, I get “Sandboxed code execution request failed.”
    4) If I run with F5 Unable to attach. Process ‘SPUCWORKERPROCESS.exe’ is not running on ‘machinename’.

    I have followed all the blogs and applied given workaround and I am not getting any trusted advise on this topic.

    I have created another fresh environment

    Configuration database version: 14.0.4762.1000

    I appreciate any help you would give us.

    02/13/2012 15:02:21.38 SPUCHostService.exe (0x07D0) 0x082C SharePoint Foundation Sandboxed Code Service fe8a Medium – – Unable to activate worker process proxy object within the worker process: ipc://1bbd771b-1d17-4dd0-b1a6-0e0bf4165a33:7000
    02/13/2012 15:02:21.38 SPUCHostService.exe (0x07D0) 0x082C SharePoint Foundation Sandboxed Code Service fe8c Medium – – Error activating the worker process manager instance within the worker process. – Inner Exception: System.InvalidOperationException: Unable to activate worker process proxy object within the worker process: ipc://1bbd771b-1d17-4dd0-b1a6-0e0bf4165a33:7000 at Microsoft.SharePoint.UserCode.SPUserCodeWorkerProcess.CreateWorkerProcessProxies()
    02/13/2012 15:02:21.38 SPUCHostService.exe (0x07D0) 0x082C SharePoint Foundation Sandboxed Code Service ei0t Medium – Process creation/initialization threw an exception. Stopping this process. “ipc://1bbd771b-1d17-4dd0-b1a6-0e0bf4165a33:7000″
    02/13/2012 15:02:21.38 SPUCHostService.exe (0x07D0) 0x082C SharePoint Foundation Sandboxed Code Service fe87 Medium – – Error activating the worker process manager instance within the worker process. – Starting worker process threw – Inner Exception: System.InvalidOperationException: Unable to activate worker process proxy object within the worker process: ipc://1bbd771b-1d17-4dd0-b1a6-0e0bf4165a33:7000 at Microsoft.SharePoint.UserCode.SPUserCodeWorkerProcess.CreateWorkerProcessProxies()

  3. Mark
    July 20, 2013 at 6:59 am

    Your PS script worked perfectly. I forgot that I had set-up SP on the domain (and single) server in one of my VMs.

  1. October 2, 2010 at 10:37 am
  2. March 1, 2012 at 3:58 am

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Follow

Get every new post delivered to your Inbox.

Join 176 other followers

%d bloggers like this: